lunes, 1 de diciembre de 2014

Una vulnerabilidad permite bloquear el WhatsApp de un amigo con un mensaje

Una vulnerabilidad permite bloquear el WhatsApp de un amigo con un mensaje

El servicio de mensajería más popular del mundo se enfrenta a un nuevo riesgo de seguridad por el cual sería posible bloquear el WhatsApp de uno de nuestros contactos mediante un simple mensaje. Las consecuencias que esto puede acarrear serían devastadoras para los millones de usuarios activos mensuales que tiene la aplicación.
Según informan en The Hacker News, una nueva vulnerabilidad descubierta haría que bloquear el WhatsApp de otra persona fuera tan simple como enviar a la misma un tipo de mensaje específico. El hallazgo ha sido obra de dos analistas de seguridad de la India, Indrajeet Bhuyan y Saurav Kar de tan solo 17 años de edad y así lo han confirmado al sitio web que ha dado la voz de alarma.


El peligroso mensaje constaría de 2000 palabras, lo que supone un tamaño de 2 Kb, usando un determinado tipo de caracteres que provocarían el colapso de la aplicación al ser recibidos por otra persona. Abrir el mensaje supone tener la aplicación bloqueada por lo que la única forma que parece haber de resolver el problema es borrar por completo la conversación y el historial de chat con el emisor del mensaje, con las molestias que esto puede provocar.
WhatsApp permite guardar las conversaciones de los contactos y enviarlas por correo electrónico en el caso de necesitarlas, pero de esta forma se forzaría a borrar las mismas con el perjuicio que puede conllevar para los usuarios que perderían de esta forma información y datos valiosos en el caso de mantenerlos en el historial pasado de la conversación. Además puede poner en jaque al servicio de mensajería en el caso de que se extendiera una peligrosa moda de bloquear el WhatsApp de otras personas ya que recordemos que esta vulnerabilidad descubierta afectaría a toda la aplicación.


WhatsApp para Android en peligro

Las posibilidades son muchas, desde forzar a gente a dejar grupos de WhatsApp a simplemente molestar a determinados usuarios. Por el momento se ha comprobado como la vulnerabilidad afectaría al sistema operativo Android incluyendo versiones de Android KitKat, JellyBean y anteriores. Por ahora no ha sido corobada en iOS por lo que se desconoce si afecta al sistema de Apple, pero tanto las versiones de WhatsApp 2.11.431 y 2.11.432 están comprometidas por el bug.
De momento la compañía no ha hecho ninguna mención oficial respecto al problema pero a buen seguro estarán desarrollando a marchas forzadas los diferentes parches para poner solución a la misma antes de que el problema pase a mayores y los usuarios puedan verse forzados a elegir otras opciones de la competencia.





Fuente: Adslzone.net

No hay comentarios:

Publicar un comentario